Ayudita en Algoritmos =D!

    Comparte

    Chipz

    Mensajes : 40
    Fecha de inscripción : 25/04/2010
    Edad : 24
    Localización : Santa Patricia - La molina

    Ayudita en Algoritmos =D!

    Mensaje por Chipz el Vie Abr 30, 2010 1:18 pm

    http://pseint.sourceforge.net/

    Donacion de Ing. ika

    JerSon

    Mensajes : 46
    Fecha de inscripción : 26/04/2010
    Edad : 23

    PSeInt programa para resolver algoritmos y mas!

    Mensaje por JerSon el Vie Abr 30, 2010 2:33 pm

    Chipz escribió:http://pseint.sourceforge.net/

    Donacion de Ing. ika

    En realidad fue donacion mia ¬¬.... ESTE PROGRAMA TE AYUDA PARA CUANDO TE DEJEN HACER INFORMES DE LABORATORIO (PD: Lalo no seas tan mente cerrada)

    bueno como chipz no explica como es ese programa lo explicare yo....

    PSeInt

    Descripcion
    PSeInt
    es una herramienta para aprender la lógica de programación, orientada a
    estudiantes sin experiencia en dicha área. Mediante la utilización de
    un simple y limitado pseudo-lenguaje intuitivo y en español, permite
    comenzar a comprender conceptos básicos y fundamentales de un algoritmo
    computacional. Nacido originalmente como proyecto final para la materia
    Programación I de la carrera Ingeniería en Informática de la Facultad de
    Ingeniería y Ciencias Hídricas de la Universidad Nacional del Litoral,
    es en realidad un intérprete de pseudocodigo basado en los contenidos de
    la cátedra de Fundamenos de Programación de dicha carrera.



    Como ya deci la intro, este es un programa que es para los que estan
    aprendiendo programacion, este programa lo podemos usar para verificar
    si nuestro Algoritmo hace lo que nosotros queres ademas de usar la tabla
    de verificacion.

    A si mismo tambien lo podemos usar para
    transformarlo en un diagrama de Flujo:



    Aca les dejo un Ejemplo de una algoritmo que le tenemos que ingresar
    numeros, y cuenta cuantos numeros iguales o mayores que 15 fueron
    introducidos por el usuario y se finaliza cuando el usuario ingresa -1.

    Proceso Algoritmo15
    Nro<-0
    Cont1<-0

    Cont2<-0
    Repetir
    Escribir "Escribir Numero";

    Leer Nro;
    Si Nro>15 entonces
    Cont1<-Cont1+1;

    Sino
    Si Nro=15 Entonces
    Cont2<-Cont2+1;

    Sino

    FinSi
    FinSi
    Hasta Que Nro=-1

    Si Nro=-1 Entonces
    Escribir "Resultados:";


    Escribir Cont1;
    Escribir "Fueron
    mayores que 15";
    Escribir Cont2;
    Escribir
    "Fueron Iguales que 15";
    FinSi


    Escribir
    "Algoritmo por Luchiok (cuenta en e4zone)";


    FinProceso


    Algoritmo Funcionando:



    EJEMPLO ESTO ES UN PUTO EJEMPLO "ESTO NO ES LO UNICO Q HACE EL PROGRAMA"
    y aca algo como una simulacion de una pelea.... Very Happy para q vean q estos codigos no son tan aburridos Very Happy

    Code:
    Proceso NoobFight
    RedLife<-200
    RedDef<-25

    RedAta<-45
    BlueLife<-190
    BlueDef<-30

    BlueAta<-35
    Ra<-0
    Ba<-0
    Escribir
    "Bienvenidos a NoobFight";
    Escribir "-------------------";

    Escribir "Datos de RedSoldier";
    Escribir "-------------------";

    Escribir "Vida:200";
    Escribir "Defesa:25";
    Escribir
    "Ataque:45";
    Escribir "-------------------";
    Escribir "Datos
    de BlueSoldier";
    Escribir "-------------------";
    Escribir
    "Vida:290";
    Escribir "Defesa:30";
    Escribir "Ataque:35";

    Escribir "-------------------";
    Escribir "-------------------";

    Escribir "Comandos a Tener en cuenta: (1=Atacar - 2=PasarTurno)";

    Escribir "-------------------";
    Escribir "Fight!";
    Repetir

    Escribir "Turno de RedSoldier";
    Escribir "¿Que desea hacer?";

    Leer Ra;
    Si Ra=1 Entonces
    BlueLife<-BlueLife-15;

    Escribir "Vida de BlueSoldier:";
    Escribir BlueLife;

    Escribir "Turno de BlueSoldier";
    Escribir "¿Que desea
    hacer?";
    Leer Ba;
    Si Ba=1 Entonces

    RedLife<-RedLife-10;
    Escribir "Vida de RedSoldier:";

    Escribir RedLife;
    Sino
    Si Ba=2
    Entonces
    Escribir "BlueSoldier Paso Turno";

    FinSi
    FinSi
    Sino
    Si Ra=2 Entonces

    Escribir "RedSoldier Paso Turno";
    Escribir "Turno de
    BlueSoldier";
    Escribir "¿Que desea hacer?";
    Leer
    Ba;
    Si Ba=1 Entonces
    RedLife<-RedLife-10;

    Sino
    Si Ba=2 Entonces
    Escribir
    "BlueSoldier Paso Turno";
    //Sino
    //
    acciones_por_falso
    FinSi
    FinSi


    //Sino
    // acciones_por_falso
    FinSi
    FinSi
    Hasta
    Que RedLife<=0 o BlueLife<=0

    Si RedLife<=0 Entonces

    Escribir "RedSoldier a muerto y ¡¡BlueSoldier Gano!!";
    Sino

    Si BlueLife<=0 Entonces
    Escribir "BlueSoldier a muerto y
    ¡¡RedSoldier Gano!!";
    Sino
    Si RedLife<=0 y
    BlueLife<=0 Entonces
    Escribir "Se Produjo un Empate";

    //Sino
    // acciones_por_falso
    FinSi
    FinSi
    FinSi
    Escribir
    "By Luchiok (cuenta en e4zone.com)";
    FinProceso





    Ojala les sea de mucha ayuda.... Ing. Yui


    Última edición por JerSon el Sáb Mayo 01, 2010 8:59 pm, editado 3 veces

    Chipz

    Mensajes : 40
    Fecha de inscripción : 25/04/2010
    Edad : 24
    Localización : Santa Patricia - La molina

    Re: Ayudita en Algoritmos =D!

    Mensaje por Chipz el Vie Abr 30, 2010 10:25 pm

    Solo te ekivocaste =D!
    es Ing. Ika

    Hiwataru
    Admin

    Mensajes : 23
    Fecha de inscripción : 25/04/2010
    Edad : 22
    Localización : G-314 (XD)

    Re: Ayudita en Algoritmos =D!

    Mensaje por Hiwataru el Vie Abr 30, 2010 11:09 pm

    Ing. Ika?

    Tomatonah♥

    Mensajes : 17
    Fecha de inscripción : 25/04/2010
    Edad : 23
    Localización : Incheon 인천광역시

    Re: Ayudita en Algoritmos =D!

    Mensaje por Tomatonah♥ el Sáb Mayo 08, 2010 12:00 am

    SSe ve bien el programa *w*
    quien es Ing. Ika''


    Tomatonah♥

    Mensajes : 17
    Fecha de inscripción : 25/04/2010
    Edad : 23
    Localización : Incheon 인천광역시

    Re: Ayudita en Algoritmos =D!

    Mensaje por Tomatonah♥ el Sáb Mayo 08, 2010 12:00 am

    SSe ve bien el programa *w*
    quien es Ing. Ika''


    JerSon

    Mensajes : 46
    Fecha de inscripción : 26/04/2010
    Edad : 23

    Re: Ayudita en Algoritmos =D!

    Mensaje por JerSon el Sáb Mayo 08, 2010 5:53 pm

    Tomatonah♥ escribió:SSe ve bien el programa *w*
    quien es Ing. Ika''


    no es ing. ika... ¬¬ es ing. yui

    ika... xq?

    Contenido patrocinado

    Re: Ayudita en Algoritmos =D!

    Mensaje por Contenido patrocinado Hoy a las 4:38 pm


      Fecha y hora actual: Lun Dic 05, 2016 4:38 pm